Subscribe
Status
Activity
Activity
Textual Outage
Started
Fri, Sep 18
Lasted 4min
MAJOR
Affects
Textual
Updates
RESOLVED
lasted 4min
The incident has been resolved
16:49
INVESTIGATING
4min earlier
Textual Website is experiencing issues.
16:44